User Tools

Site Tools


gnuplot

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Next revision
Previous revision
gnuplot [2024/05/06 17:36] – created dblumegnuplot [2024/05/08 10:17] (current) – [GnuPlot 6.0] dblume
Line 2: Line 2:
  
 GnuPlot 6.0 adds ''set term block'' to use Unicode block or Braille characters for your dumb terminals that support them. GnuPlot 6.0 adds ''set term block'' to use Unicode block or Braille characters for your dumb terminals that support them.
 +
 +These two plots are of AirPassengers.csv, the top using Braille, the bottom using term "dumb". The Braille is so much better.
 +{{:general:gnuplot_braille.png|}}
  
 ===== Instructions for compiling ===== ===== Instructions for compiling =====
Line 12: Line 15:
   sudo make install   sudo make install
  
-  +===== Instructions for WSL ===== 
 + 
 +  ./prepare 
 +  ./configure --with-bitmap-terminals --with-qt=no 
 +  make 
 +  sudo make install 
 + 
 +If ''prepare'' complains that aclocal is not found, you also need... 
 + 
 +  sudo apt-get install automake 
 +  # sudo apt-get install pkg-config (Maybe this was only for QT?) 
 + 
 + 
 +===== Instructions for macOS ===== 
 + 
 +Inspired from this [[https://stackoverflow.com/questions/54296621/brew-install-gnuplot-with-qt-with-x11-not-working|StackOverflow answer]]. I gave up on getting QT working. 
 + 
 +  brew install readline 
 +  brew install pkg-config 
 +  # ... Get the sources per instructions above ... 
 +  ./prepare 
 +  ./configure --disable-silent-rules --prefix=/opt/homebrew/opt/gnuplot --with-readline=/opt/homebrew/opt/readline --with-cairo --with-qt=no --with-x --with-bitmap-terminals 
 +  make 
 +  sudo make install
gnuplot.1715042180.txt.gz · Last modified: 2024/05/06 17:36 by dblume